ggLeap File Download Issue

Resolved
Major outage
Started 12 months ago Lasted 1 day

Affected

ggLeap
Desktop Client
Updates
  • Resolved
    Resolved

    Major systems are now back online and normal functionality should be restored.

    We continue to restore secondary and tertiary backend systems, so please do continue to report any issues you encounter so that we may work to prioritize them.

  • Identified
    Update

    We are continuing to work on a fix for this incident.

    We are prioritizing items that are affecting you the most as services are restored.

    Please reach out to us via web support chat with any issues you are encountering so that we may address them more quickly by prioritizing.

    Most of the critical systems have been restored.

    Thank you for your patience.

  • Identified
    Update

    We are continuing to work on a fix for this incident.

    The team have provided an ETA of ~3 Hours for major operations related to the restoration of service to be completed.

  • Identified
    Update

    We are continuing to work on a fix for this incident.

    In the short term, you might find the client loads more quickly by temporarily disabling your games and encouraging patrons to open the individual launchers (Steam, EA, etc) to access installed game titles.

    1. Navigate to the "Settings" menu.
    2. Select "Client Configuration."
    3. Click on "Games/Apps."
    4. Ensure that the "Enabled" option is selected.
    5. Proceed to disable all games except for Battle.net, Epic Games, Steam, EA, Rockstar, Discord, and FiveM.

    Once you have disabled the desired games, restart the the client computers. This should result in faster loading times for GGLeap.
    It is important to remember the games you have disabled, so you can re-enable them once the issue is resolved.

    Stay tuned for further updates as we continue bringing this issue to a resolution.

  • Identified
    Identified

    We made a mistake while trying to improve the way we run our platform, which caused some unexpected issues. As a result, client launch operations have been negatively impacted. We want to assure you that our team is actively working to fix the problem as quickly as possible.

    We understand that this situation may be frustrating, but please bear with us while we resolve the issue. We will provide regular updates here to keep you informed about our progress. Thank you for your patience and understanding.

    We are continuing to work on a fix for this incident.

    Until the issue is resolved, it will be necessary to reboot any systems that are stuck at the ggLeap login screen, then click "OK" when assets fail to download so that the client will continue loading.

    We apologize for this inconvenience and will provide additional information as soon as it is available.